Java 1.7 Installation Fail with The Error GLIBC_2.4 Not Found

Posted by Agung Pambudi on
[user@test ~]$ java
Error: dl failure on line 864
Error: failed /usr/java/jdk1.7.0_25/jre/lib/amd64/server/libjvm.so, because /lib64/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.7.0_25/jre/lib/amd64/server/libjvm.so)
[user@test ~]$


You can not run JRE 1.7 on RHEL 3.8 or 4.6. They are too old. The minimum version for JRE 1.7 on RHEL is RHEL 5.5. Thus, you must use RHEL 5.5+. I upgraded to Redhat Linux Enterprise 6.5 and resolve it.

In fact the easier way to fix the issue is to upgrade your OS version.

1 comment:


  1. I am interested in your article, I also have the same article about the video that you can visit at Here

    ReplyDelete